about summary refs log tree commit diff
path: root/tvix/tracing/default.nix
diff options
context:
space:
mode:
authorSimon Hauser <simon.hauser@helsinki-systems.de>2024-06-27T08·27+0200
committerSimon Hauser <simon.hauser@helsinki-systems.de>2024-07-02T13·43+0000
commit618aacaa61972c3e25b8c996abfa1d4dc475154e (patch)
tree7fc41bff9ed6e21b36d6768ffd457590f89dba6e /tvix/tracing/default.nix
parent7f8da5e6a9926170be2fefc1db847166e5631f16 (diff)
feat(tvix/tracing): http trace propagation r/8339
Introduces a helper function within tvix-tracing that returns a reqwest
tracing middleware that will ingest the traceparent if otlp is enabled.

It is feature flagged in tvix-tracing so not every consumer of that
library automatically has reqwest in its dependencies.

Tested using netcat to verify that the `traceparent` header is there if
otlp is enabled and missing if otlp feature is disabled.

Change-Id: I5abccae777b725f5ff7382e3686165383c477a39
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11886
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/tracing/default.nix')
-rw-r--r--tvix/tracing/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tvix/tracing/default.nix b/tvix/tracing/default.nix
index dd7dc200f2c6..a4ac9de1c8bc 100644
--- a/tvix/tracing/default.nix
+++ b/tvix/tracing/default.nix
@@ -6,6 +6,6 @@
   meta.ci.targets = lib.filter (x: lib.hasPrefix "with-features" x || x == "no-features") (lib.attrNames passthru);
   passthru = depot.tvix.utils.mkFeaturePowerset {
     inherit (old) crateName;
-    features = [ "otlp" "tracy" ];
+    features = [ "otlp" "tracy" "tonic" "reqwest" ];
   };
 })