about summary refs log tree commit diff
path: root/tvix/tracing/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-06-14T11·10+0300
committerflokli <flokli@flokli.de>2024-06-14T19·33+0000
commit6b6a34065e050417e8aafab8915a2cee270cc09d (patch)
treef30975995e430586439897109221e38f9e70b159 /tvix/tracing/Cargo.toml
parentd25f047b9d12bab692e61f6bbdc4c8d673914f34 (diff)
feat(tvix/tracing): add tracing-tracy support r/8275
This introduces another feature flag, "tracy" to the `tvix-tracing` crate.

If enabled (not enabled by default), it'll add an additional layer
emitting packets in a format that https://github.com/wolfpld/tracy can
display.

I had to be a bit tricky with the combinatorial complexity when adding
this, but the resulting code still seems manageable.

Change-Id: Ica824496728fa276ceae3f7a9754be0166e6558f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10952
Tested-by: BuildkiteCI
Reviewed-by: Simon Hauser <simon.hauser@helsinki-systems.de>
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/tracing/Cargo.toml')
-rw-r--r--tvix/tracing/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/tvix/tracing/Cargo.toml b/tvix/tracing/Cargo.toml
index 41654d00c02f..490f086a27f3 100644
--- a/tvix/tracing/Cargo.toml
+++ b/tvix/tracing/Cargo.toml
@@ -16,6 +16,7 @@ tracing-opentelemetry = { version = "0.23.0", optional = true }
 opentelemetry = { version = "0.22.0", optional = true }
 opentelemetry-otlp = { version = "0.15.0", optional = true }
 opentelemetry_sdk = { version = "0.22.1", features = ["rt-tokio"], optional = true }
+tracing-tracy = { version = "0.11.0", features = ["flush-on-exit"], optional = true }
 
 [features]
 default = []
@@ -25,6 +26,9 @@ otlp = [
   "dep:opentelemetry-otlp",
   "dep:opentelemetry_sdk"
 ]
+tracy = [
+  "dep:tracing-tracy"
+]
 
 [lints]
 workspace = true