about summary refs log tree commit diff
path: root/tvix/tools/weave/Cargo.toml
diff options
context:
space:
mode:
authoredef <edef@edef.eu>2024-02-15T22·20+0000
committeredef <edef@edef.eu>2024-02-27T11·50+0000
commite3860689babdf09a1e295e3640389467987b5611 (patch)
tree5936180456b49fa40d7367bdb278d05be6afe402 /tvix/tools/weave/Cargo.toml
parent692f2bfb1c189f6de4cb733f9b1c68a2b2e56eef (diff)
feat(tvix/tools/weave): init r/7617
Scalable tracing GC for the cache.nixos.org dataset.

Change-Id: I6c7852796f28e1a1c7607384ffb55f44407e1185
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10765
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/tools/weave/Cargo.toml')
-rw-r--r--tvix/tools/weave/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/tvix/tools/weave/Cargo.toml b/tvix/tools/weave/Cargo.toml
new file mode 100644
index 000000000000..7c6c2d2f0cf6
--- /dev/null
+++ b/tvix/tools/weave/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "weave"
+version = "0.1.0"
+edition = "2021"
+
+[workspace]
+members = ["."]
+
+# TODO(edef): cut down on required features, this is kind of a grab bag right now
+[dependencies]
+anyhow = { version = "1.0.79", features = ["backtrace"] }
+hashbrown = "0.14.3"
+nix-compat = { version = "0.1.0", path = "../../nix-compat" }
+owning_ref = "0.4.1"
+rayon = "1.8.1"
+tokio = { version = "1.36.0", features = ["full"] }
+
+[dependencies.polars]
+version = "0.36.2"
+features = ["parquet"]