about summary refs log tree commit diff
path: root/tvix/tools/turbofetch/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@tvl.su>2023-11-22T07·41+0300
committerclbot <clbot@tvl.fyi>2023-11-27T21·16+0000
commit360c98ce38a8eb94ab3955f4ed46c3a2e709bb74 (patch)
tree7418ccb4474ed0a57098501d035c677f87a830ef /tvix/tools/turbofetch/default.nix
parent0415bc6fd26ba5a20f81e2327305dc0ebfceb3b9 (diff)
chore(3p/sources): bump channels & overlays (2023-11-27) r/7076
* picked avrdude from stable channel
* removed override for texlive, as the upstream fix is merged
* picked awscli2 from stable channel
* bump tdlib to 1.8.21 (new minimum for telega.el)
* tvix/turbofetch: switch to nixpkgs-native mechanism for
  CARGO_MANIFEST_LINKS (whatever that is)

Change-Id: Ic695721b5ca750b89d21cab7a257e1db682b23c0
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10083
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to '')
-rw-r--r--tvix/tools/turbofetch/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/tvix/tools/turbofetch/default.nix b/tvix/tools/turbofetch/default.nix
index b7b6a052d7..bd70f6a5e6 100644
--- a/tvix/tools/turbofetch/default.nix
+++ b/tvix/tools/turbofetch/default.nix
@@ -2,9 +2,9 @@
 
 (pkgs.callPackage ./Cargo.nix {
   defaultCrateOverrides = pkgs.defaultCrateOverrides // {
+
     ring = prev: {
-      # TODO(edef): implement CARGO_MANIFEST_LINKS in crate2nix
-      CARGO_MANIFEST_LINKS = ''ring_core_${lib.replaceStrings ["."] ["_"] prev.version}'';
+      links = ''ring_core_${lib.replaceStrings ["."] ["_"] prev.version}'';
     };
   };
 }).rootCrate.build.override {