about summary refs log tree commit diff
path: root/tvix/tools/crunch-v2/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-01-25T12·47+0200
committerclbot <clbot@tvl.fyi>2024-01-27T18·40+0000
commitb38be028d96ce107439f3323026270228a871a13 (patch)
tree991bc6341714a3896645240309d88dc20784f90e /tvix/tools/crunch-v2/Cargo.toml
parent4f22203a3aecd070881ae9b4eabc47532d948f01 (diff)
feat(tvix/tools/crunch-v2): add CLI args r/7453
Use clap derive to make the input and output files configurable, as well
as the chunk size parameters.

Change-Id: I02b29126f3bd2c13ba2c6e7e0aa4ff048ff803ed
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10691
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Reviewed-by: edef <edef@edef.eu>
Diffstat (limited to 'tvix/tools/crunch-v2/Cargo.toml')
-rw-r--r--tvix/tools/crunch-v2/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/tools/crunch-v2/Cargo.toml b/tvix/tools/crunch-v2/Cargo.toml
index eb44805d7c2c..1e3f0252504d 100644
--- a/tvix/tools/crunch-v2/Cargo.toml
+++ b/tvix/tools/crunch-v2/Cargo.toml
@@ -33,6 +33,7 @@ zstd = "0.13.0"
 prost = "0.12.2"
 polars = { version = "0.35.4", default-features = false, features = ["parquet", "lazy", "sql", "dtype-struct"] }
 indicatif = "0.17.7"
+clap = { version = "4.4.18", features = ["derive"] }
 
 [build-dependencies]
 prost-build = "0.12.2"