about summary refs log tree commit diff
path: root/tvix/store/protos/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-10-17T12·42+0100
committerflokli <flokli@flokli.de>2023-10-17T19·51+0000
commit1b26bf21e3305232b9bbdc928a063da9be9eaee0 (patch)
treed5ee335a6c76cc54095266ec685e4a8dae515a2e /tvix/store/protos/default.nix
parente38733a955f6f6fc8962cf0e669d9cf4696bc14d (diff)
chore(tvix): move store golang bindings to tvix/store-go r/6844
Similar to the castore-go CL before, this also updates the store-go
bindings to the new layout.

Change-Id: Id73d7ad43f7d70171ab021728e303300c5db71f0
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9788
Tested-by: BuildkiteCI
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Diffstat (limited to 'tvix/store/protos/default.nix')
-rw-r--r--tvix/store/protos/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/tvix/store/protos/default.nix b/tvix/store/protos/default.nix
new file mode 100644
index 0000000000..5f56eda79b
--- /dev/null
+++ b/tvix/store/protos/default.nix
@@ -0,0 +1,34 @@
+{ depot, pkgs, ... }: {
+  # Produces the golang bindings.
+  go-bindings = pkgs.stdenv.mkDerivation {
+    name = "go-bindings";
+
+    src = depot.nix.sparseTree {
+      name = "castore-protos";
+      root = depot.path.origSrc;
+      paths = [
+        # We need to include castore.proto (only), as it's referred.
+        ../../castore/protos/castore.proto
+        ./pathinfo.proto
+        ./rpc_pathinfo.proto
+        ../../../buf.yaml
+        ../../../buf.gen.yaml
+      ];
+    };
+
+    nativeBuildInputs = [
+      pkgs.buf
+      pkgs.protoc-gen-go
+      pkgs.protoc-gen-go-grpc
+    ];
+
+    buildPhase = ''
+      export HOME=$TMPDIR
+      buf lint
+      buf generate
+
+      mkdir -p $out
+      cp tvix/store/protos/*.pb.go $out/
+    '';
+  };
+}