about summary refs log tree commit diff
path: root/tvix/store/protos/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-07-13T21·12+0300
committertazjin <tazjin@tvl.su>2023-08-08T20·11+0000
commitfcda0682357f1ec531c494dac5aa49ba8ae8851a (patch)
treea196355edfcd975bdd42eaf7ab25bfa3e110abd5 /tvix/store/protos/default.nix
parent33fa42a1a33dd0e5cae2573f764f26a73b6ad72e (diff)
feat(nix/sparseTree): add optional `name` argument r/6472
This allows pinning the name of the sparse tree derivation, which
stops the continous rebuilding of tvix-store-proto dependents.

I've opted to let the function take an attribute set instead and
refactored the call sites appropriately.

Change-Id: I3e57785094b1adbfffa24caf9f1c3384844fa200
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8965
Reviewed-by: grfn <grfn@gws.fyi>
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'tvix/store/protos/default.nix')
-rw-r--r--tvix/store/protos/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/tvix/store/protos/default.nix b/tvix/store/protos/default.nix
index 0ffdcac041..d5c4484222 100644
--- a/tvix/store/protos/default.nix
+++ b/tvix/store/protos/default.nix
@@ -9,4 +9,8 @@ let
   protoFileNames = filter (hasSuffix ".proto") (attrNames (readDir ./.));
   protoFiles = map (f: ./. + ("/" + f)) protoFileNames;
 in
-depot.nix.sparseTree depot.path.origSrc protoFiles
+depot.nix.sparseTree {
+  name = "tvix-store-protos";
+  root = depot.path.origSrc;
+  paths = protoFiles;
+}