about summary refs log tree commit diff
path: root/tvix/store/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-07-07T14·16+0300
committerclbot <clbot@tvl.fyi>2024-07-07T15·11+0000
commitd17c3d96b61a38b8a1900ca3b08bafff8e863cd2 (patch)
tree15faeaa4efedfb9c6fdfc0841c32711c7ed7e9fd /tvix/store/default.nix
parent89d204d295345af6b64b2c5d515cfcf02828abf5 (diff)
refactor(tvix): point SSL_CERT_FILE to /dev/null r/8357
reqwest wants to be able to read a file of trust roots when constructed,
but as it doesn't actually do any HTTPS connections inside the nix
build, an empty list of trust roots is totally sufficient.

Thankfully /dev/null provides such a file.

Change-Id: I9bd1619b2c9f8ff2a6640d2ac410d4de5b20c2ea
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11961
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Reviewed-by: aspen <root@gws.fyi>
Diffstat (limited to 'tvix/store/default.nix')
-rw-r--r--tvix/store/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/tvix/store/default.nix b/tvix/store/default.nix
index 3fe47fe60b11..d5d4609beff9 100644
--- a/tvix/store/default.nix
+++ b/tvix/store/default.nix
@@ -25,7 +25,7 @@ in
 (depot.tvix.crates.workspaceMembers.tvix-store.build.override (old: {
   runTests = true;
   testPreRun = ''
-    export SSL_CERT_FILE=${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt
+    export SSL_CERT_FILE=/dev/null
   '';
   features = old.features
     # virtiofs feature currently fails to build on Darwin
@@ -41,13 +41,13 @@ in
       # virtiofs feature currently fails to build on Darwin
       ++ lib.optional pkgs.stdenv.isLinux "virtiofs");
     override.testPreRun = ''
-      export SSL_CERT_FILE=${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt
+      export SSL_CERT_FILE=/dev/null
     '';
   }) // {
     integration-tests = depot.tvix.crates.workspaceMembers.${old.crateName}.build.override (old: {
       runTests = true;
       testPreRun = ''
-        export SSL_CERT_FILE=${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt;
+        export SSL_CERT_FILE=/dev/null
         export PATH="$PATH:${pkgs.lib.makeBinPath [ pkgs.cbtemulator pkgs.google-cloud-bigtable-tool ]}"
       '';
       features = old.features ++ [ "integration" ];