about summary refs log tree commit diff
path: root/tvix/store/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-01-02T13·37+0100
committerflokli <flokli@flokli.de>2023-01-03T13·03+0000
commitceb2c0ba895554c7cabb0ac20d3a80ea2aba1ab1 (patch)
tree427ee29cd8883bc1159a58e7f6e92a8d673b155e /tvix/store/default.nix
parentd0bbc8c8214fe164be572a0c2b1bd28f79fc1d20 (diff)
chore(tvix/store): make importable r/5569
This allows other crates to import tvix_store.

Rename the bin crate to tvix-store-bin, to avoid having multiple crates
with the same name (https://github.com/rust-lang/cargo/issues/6313)

Change-Id: I857768d6115640dbf102e79ed03e8474090df2fe
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7728
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/store/default.nix')
-rw-r--r--tvix/store/default.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/tvix/store/default.nix b/tvix/store/default.nix
index 68b529e723..65289cacc8 100644
--- a/tvix/store/default.nix
+++ b/tvix/store/default.nix
@@ -11,7 +11,7 @@ let
 
   protobufDep = prev: (prev.nativeBuildInputs or [ ]) ++ [ pkgs.protobuf ];
 in
-depot.tvix.crates.workspaceMembers.tvix-store.build.override {
+depot.tvix.crates.workspaceMembers.tvix-store-bin.build.override {
   # Ensure protobuf dependencies are available.
   # TODO: figure out a way to embed this directly in the //tvix
   # crate2nix config.
@@ -28,6 +28,11 @@ depot.tvix.crates.workspaceMembers.tvix-store.build.override {
       PROTO_ROOT = protoRoot;
       nativeBuildInputs = protobufDep prev;
     };
+
+    tvix-store-bin = prev: {
+      PROTO_ROOT = protoRoot;
+      nativeBuildInputs = protobufDep prev;
+    };
   };
 
   runTests = true;