about summary refs log tree commit diff
path: root/tvix/store/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-01-06T17·20+0300
committertazjin <tazjin@tvl.su>2023-01-06T17·57+0000
commit3e03e59893b77b0b3915224967b377f6e940670d (patch)
treec2fd130c402a651e0e9c3dab87469976a856d3b0 /tvix/store/default.nix
parent144d010515c5a92c4a8ee05b95a913973f8bc6f2 (diff)
refactor(tvix/store): move protobuf build config one level up r/5615
This embeds the build config directly at the point where `Cargo.nix`
is imported, making it transparent to library consumers.

Change-Id: I5586e12f02ed14587c32d9ef7d93f079366fb127
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7780
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/store/default.nix')
-rw-r--r--tvix/store/default.nix36
1 files changed, 1 insertions, 35 deletions
diff --git a/tvix/store/default.nix b/tvix/store/default.nix
index 65289cacc8..3d873a097e 100644
--- a/tvix/store/default.nix
+++ b/tvix/store/default.nix
@@ -1,39 +1,5 @@
-{ depot, pkgs, ... }:
+{ depot, ... }:
 
-let
-  protoRoot = depot.nix.sparseTree depot.path.origSrc [
-    ./protos/castore.proto
-    ./protos/pathinfo.proto
-    ./protos/rpc_blobstore.proto
-    ./protos/rpc_directory.proto
-    ./protos/rpc_pathinfo.proto
-  ];
-
-  protobufDep = prev: (prev.nativeBuildInputs or [ ]) ++ [ pkgs.protobuf ];
-in
 depot.tvix.crates.workspaceMembers.tvix-store-bin.build.override {
-  # Ensure protobuf dependencies are available.
-  # TODO: figure out a way to embed this directly in the //tvix
-  # crate2nix config.
-  crateOverrides = {
-    prost-build = prev: {
-      nativeBuildInputs = protobufDep prev;
-    };
-
-    tonic-reflection = prev: {
-      nativeBuildInputs = protobufDep prev;
-    };
-
-    tvix-store = prev: {
-      PROTO_ROOT = protoRoot;
-      nativeBuildInputs = protobufDep prev;
-    };
-
-    tvix-store-bin = prev: {
-      PROTO_ROOT = protoRoot;
-      nativeBuildInputs = protobufDep prev;
-    };
-  };
-
   runTests = true;
 }