about summary refs log tree commit diff
path: root/tvix/store/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2022-11-26T01·14+0000
committerflokli <flokli@flokli.de>2022-12-30T20·25+0000
commit0bf2b0ef1164aae0ad692066e8cfc0b243a89e4d (patch)
treeba915b00f113395c55cc8094dfdd0b020de579cc /tvix/store/default.nix
parent51243007f67019d0d57b6cfaff2aec3191afa180 (diff)
feat(tvix/store): implement reflection r/5557
This implements grpc.reflection.v1alpha.ServerReflection, and will make tools
like evans automatically discover available services, without having to
specify the path to the .proto files client-side.

It's behind a reflection feature flag, which is enabled by default.

Change-Id: Icbcb5eb05ceede5b9952e38a2ba72eaa6fa8a437
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7435
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/store/default.nix')
-rw-r--r--tvix/store/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/tvix/store/default.nix b/tvix/store/default.nix
index 1dbf019235..68b529e723 100644
--- a/tvix/store/default.nix
+++ b/tvix/store/default.nix
@@ -20,6 +20,10 @@ depot.tvix.crates.workspaceMembers.tvix-store.build.override {
       nativeBuildInputs = protobufDep prev;
     };
 
+    tonic-reflection = prev: {
+      nativeBuildInputs = protobufDep prev;
+    };
+
     tvix-store = prev: {
       PROTO_ROOT = protoRoot;
       nativeBuildInputs = protobufDep prev;