about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-12-23T10·24+0200
committerclbot <clbot@tvl.fyi>2023-12-24T15·44+0000
commit8d86d2f4094190e141da1d3c8bcb67181edfa211 (patch)
treef09cdbb541fedececbd20ccd042408b9f3a148bc /tvix/store/Cargo.toml
parent6af17545bf7ed58f4fa2c0d5269abb5bdce35f94 (diff)
refactor(tvix/castore): add RootNode impl for BTreeMap, mv fs tests r/7258
cl/10378 did already move store/fs to castore/fs, but we kept the tests
in tvix-store, as they were populating a PathInfoService to make nodes
appear in the mount root.

Update these tests to now just insert root nodes into a BTreeMap, and
ensure we can use that as a RootNodes too.

Change-Id: Iad7d1ee4f9423eb6e3a1da33f433842c9ae0de1f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10410
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Autosubmit: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml3
1 files changed, 0 insertions, 3 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index 0a8e690e82..b3a0ae3a32 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -47,9 +47,6 @@ test-case = "2.2.2"
 tempfile = "3.3.0"
 tokio-retry = "0.3.0"
 
-[dev-dependencies.libc]
-version = "0.2.144"
-
 [features]
 default = ["fuse", "tonic-reflection"]
 fuse = ["tvix-castore/fuse"]