about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-03-10T15·18+0100
committerclbot <clbot@tvl.fyi>2023-03-11T14·12+0000
commite4687765d79bc07c1252743fe655f0c054ef9ead (patch)
tree2cc466a9c5b9f10a3a8ac1d8e253c9bcbc3fe5b2 /tvix/store/Cargo.toml
parentb049b88d2d7bcb9caef158ffdf9cd931c62d2511 (diff)
refactor(tvix/store): bump fastcdc dep r/5953
This removes the use of Box::new, switching fastcdc to version 3.0.2
with https://github.com/nlfiedler/fastcdc-rs/issues/25 fixed.

Change-Id: I64f388b9e0a7f358e25a8bb7ca0e4df1d3bb01c4
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8249
Tested-by: BuildkiteCI
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Reviewed-by: tazjin <tazjin@tvl.su>
Autosubmit: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index 65d3420ab7..ac495b63b8 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -12,7 +12,7 @@ blake3 = { version = "1.3.1", features = ["rayon", "std"] }
 clap = { version = "4.0", features = ["derive", "env"] }
 count-write = "0.1.0"
 data-encoding = "2.3.3"
-fastcdc = "3.0.0"
+fastcdc = "3.0.2"
 lazy_static = "1.4.0"
 nix-compat = { path = "../nix-compat" }
 prost = "0.11.2"