about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-05-11T15·01+0300
committerflokli <flokli@flokli.de>2023-05-24T09·25+0000
commit5774117d5ea4115a33923640a39a553eb57df59a (patch)
tree2e77cdb73837f688a7bc268366d6846ef5a503f9 /tvix/store/Cargo.toml
parent4b00f1d7ac855e90e15633a2e2ba3a90c3921fac (diff)
feat(tvix/store): implement TvixStoreIO r/6191
This providesEvalIO, asking given PathInfoService, DirectoryService
and BlobService.

Change-Id: I32f210f5a7aa8173ad9a7d53e8a5ac03619f527a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8561
Tested-by: BuildkiteCI
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index be282dddb0..a88bdefd7a 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -15,6 +15,7 @@ prost = "0.11.2"
 rayon = "1.6.1"
 sha2 = "0.10.6"
 sled = { version = "0.34.7", features = ["compression"] }
+tvix-eval = { path = "../eval" }
 thiserror = "1.0.38"
 tokio-stream = "0.1.14"
 tokio = { version = "1.28.0", features = ["rt-multi-thread", "net"] }
@@ -26,6 +27,8 @@ tokio-util = { version = "0.7.8", features = ["io", "io-util"] }
 tower = "0.4.13"
 futures = "0.3.28"
 bytes = "1.4.0"
+smol_str = "0.2.0"
+serde_json = "1.0"
 
 [dependencies.tonic-reflection]
 optional = true