about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-05-10T04·51+0300
committerclbot <clbot@tvl.fyi>2024-05-11T13·55+0000
commitfe20ba5ffc888a0b62a97b8bd29fcdd07e7851f6 (patch)
tree24ae4c5fcd746193b0024a60dbacc2fec9826ea8 /tvix/store/Cargo.toml
parenta49c32ef420e48bac8207b5dd6a74dc37130dbb1 (diff)
feat(tvix/store): add LruPathInfoService r/8106
This provides an implementation of PathInfoService storing PathInfo in
memory up to a certain capacity, then evicting these that have been used
the least recently.

Change-Id: I9d738687caf4f181a957f72245f26b92832313cd
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11622
Tested-by: BuildkiteCI
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Autosubmit: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index f82cdef300..bf04e9a1fb 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -41,6 +41,7 @@ tvix-castore = { path = "../castore" }
 url = "2.4.0"
 walkdir = "2.4.0"
 reqwest = { version = "0.11.22", features = ["rustls-tls-native-roots", "stream"], default-features = false }
+lru = "0.12.3"
 
 [dependencies.tonic-reflection]
 optional = true