about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2022-12-29T20·39+0100
committerflokli <flokli@flokli.de>2023-01-12T10·11+0000
commit43f6aec384978da8ba554f14ba89959051b47d94 (patch)
tree2359f79ec564a748b6d3bcd7b9daf83db3af4aa1 /tvix/store/Cargo.toml
parentcfa42fd19aa58ee10d3b1660f4f1bb7b2efdfccc (diff)
feat(tvix/store): implement PathInfoService with sled r/5649
This uses [sled](https://github.com/spacejam/sled) to store PathInfo
objects.

Change-Id: I12e8032e5562af8f884efa23a78049fd1108fdbc
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7726
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index abbd9b0dcb..0f1dd50e2b 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -13,6 +13,7 @@ data-encoding = "2.3.3"
 lazy_static = "1.4.0"
 clap = { version = "4.0", features = ["derive", "env"] }
 prost = "0.11.2"
+sled = { version = "0.34.7", features = ["compression"] }
 thiserror = "1.0.38"
 tokio = { version = "1.23.0", features = ["rt-multi-thread"] }
 tokio-stream = "0.1.11"
@@ -30,6 +31,7 @@ tonic-build = "0.8.2"
 
 [dev-dependencies]
 test-case = "2.2.2"
+tempfile = "3.3.0"
 
 [features]
 default = [