about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-05-28T07·22+0200
committerflokli <flokli@flokli.de>2023-06-10T14·48+0000
commit83c1546b9ad7c85dba30cb033b31e844e2401e68 (patch)
tree8fef8bf6769b83ebc744cfa895548fb9b287a7e0 /tvix/store/Cargo.toml
parent723186c5add2807fce464dc64d9ff0204cf3d3da (diff)
chore(tvix/store): add fuse feature r/6261
This brings in fuse (via the `fuser` crate), and adds pkg-config and
libfuse to the dev shell, so `cargo build` can link against it.

Change-Id: I0d11607490e27d946bdf92b0b9e45f9ab644ba74
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8664
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml11
1 files changed, 10 insertions, 1 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index a88bdefd7a..3b2765f992 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -30,10 +30,18 @@ bytes = "1.4.0"
 smol_str = "0.2.0"
 serde_json = "1.0"
 
+[dependencies.fuser]
+optional = true
+version = "0.12.0"
+
 [dependencies.tonic-reflection]
 optional = true
 version = "0.5.0"
 
+[dependencies.libc]
+optional = true
+version = "0.2.144"
+
 [build-dependencies]
 prost-build = "0.11.2"
 tonic-build = "0.8.2"
@@ -44,5 +52,6 @@ tempfile = "3.3.0"
 tonic-mock = { git = "https://github.com/brainrake/tonic-mock", branch = "bump-dependencies" }
 
 [features]
-default = ["reflection"]
+default = ["fuse", "reflection"]
+fuse = ["dep:fuser", "dep:libc"]
 reflection = ["tonic-reflection"]