about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-01-21T13·18+0100
committerflokli <flokli@flokli.de>2023-01-21T15·12+0000
commit1a84e3e6d800fed1709364174d4a615b1d146ad0 (patch)
treee08cddc3d30c4796402ecc70c3c637b11f322f4c /tvix/store/Cargo.toml
parent4614db2f83b42f6026beee9fa60d36aabec2e3de (diff)
chore(tvix/store): add fastcdc crate r/5727
This is used for content-defined chunking.

Change-Id: I10345372cecb9a643cc51ca45aa5b77d2a05198a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7889
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml9
1 files changed, 3 insertions, 6 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index b306a11f44..151d985c82 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -20,6 +20,7 @@ tokio-stream = "0.1.11"
 tonic = "0.8.2"
 tracing-subscriber = "0.3.16"
 tracing = "0.1.37"
+fastcdc = "2.0.0"
 
 [dependencies.tonic-reflection]
 optional = true
@@ -35,9 +36,5 @@ tempfile = "3.3.0"
 tonic-mock = { git = "https://github.com/brainrake/tonic-mock", branch = "bump-dependencies" }
 
 [features]
-default = [
-  "reflection"
-]
-reflection = [
-  "tonic-reflection"
-]
+default = ["reflection"]
+reflection = ["tonic-reflection"]