about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-01-31T11·18+0100
committerflokli <flokli@flokli.de>2023-01-31T13·26+0000
commitc27bacd905a14207edc56850fd4ef9383706b5c4 (patch)
tree197b49a52c0ab6a05196b82cbe2071b3eed5eaa0 /tvix/store/Cargo.toml
parent8ea93bb646456864088a2c93e9ab2c4ccae75cba (diff)
refactor(tvix): introduce nix-compat crate r/5788
Move nixbase32 and store_path into this.

This allows //tvix/cli to not pull in //tvix/store for now.

Change-Id: Id3a32867205d95794bc0d33b21d4cb3d9bafd02a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7964
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index 151d985c82..769b496235 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -14,9 +14,10 @@ lazy_static = "1.4.0"
 clap = { version = "4.0", features = ["derive", "env"] }
 prost = "0.11.2"
 sled = { version = "0.34.7", features = ["compression"] }
+nix-compat = { path = "../nix-compat" }
 thiserror = "1.0.38"
-tokio = { version = "1.23.0", features = ["rt-multi-thread"] }
 tokio-stream = "0.1.11"
+tokio = { version = "1.23.0", features = ["rt-multi-thread"] }
 tonic = "0.8.2"
 tracing-subscriber = "0.3.16"
 tracing = "0.1.37"