about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-03-14T21·36+0100
committerflokli <flokli@flokli.de>2023-03-14T22·23+0000
commit36bed4ce57c4af353b4ae8533bb97574bf3004e8 (patch)
treeaaf151ce9a78229bee82f96fc100d93958d3e6eb /tvix/store/Cargo.toml
parent0094a1442a2c6baed558fd9dedeb778c2129ce6a (diff)
chore(tvix/store): drop separate bin package r/6007
Apparently, having multiple packages with the same path is a bad thing:

```
The bin target `tvix-store` in package `tvix-store-bin v0.1.0 (/home/flokli/tvl/tvix/store)` has the same output filename as the lib target `tvix_store` in package `tvix-store-bin v0.1.0 (/home/flokli/tvl/tvix/store)`.
Colliding filename is: /home/flokli/tvl/tvix/target/doc/tvix_store/index.html
The output filenames should be unique.
This is a known bug where multiple crates with the same name use
the same path; see <https://github.com/rust-lang/cargo/issues/6313>.
```

Change-Id: Ic785c0349070783baf5e8fd23f5fb60603a3c995
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8308
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml5
1 files changed, 1 insertions, 4 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index 793c75a9d8..569b78076a 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -1,11 +1,8 @@
 [package]
-name = "tvix-store-bin"
+name = "tvix-store"
 version = "0.1.0"
 edition = "2021"
 
-[lib]
-name = "tvix_store"
-
 [dependencies]
 anyhow = "1.0.68"
 blake3 = { version = "1.3.1", features = ["rayon", "std"] }