about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2022-11-12T23·23+0000
committerflokli <flokli@flokli.de>2022-12-26T11·38+0000
commit3676ce8d6dc30a5439beec4a705a416597124435 (patch)
treecef3871ee8ebd3d343b6e831ac29e726900e5d56 /tvix/store/Cargo.toml
parent7fbac93940a44cf6b790aba16d316d9531558187 (diff)
feat(tvix/store): use tonic-build for protos r/5492
While prost-build already exposes protobuf message types as structs, we
actually need tonic-build too, to be able to get traits for all the RPC
services defined in the proto files.

Change-Id: I7f4c08454bf0d280d577975c7cdae13ccc2d933b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7320
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index c807da760a..2e03788067 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -6,6 +6,8 @@ edition = "2021"
 [dependencies]
 blake3 = { version = "1.3.1", features = ["rayon", "std"] }
 prost = "0.11.2"
+tonic = "0.8.2"
 
 [build-dependencies]
 prost-build = "0.11.2"
+tonic-build = "0.8.2"