about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2022-11-26T01·14+0000
committerflokli <flokli@flokli.de>2022-12-30T20·25+0000
commit0bf2b0ef1164aae0ad692066e8cfc0b243a89e4d (patch)
treeba915b00f113395c55cc8094dfdd0b020de579cc /tvix/store/Cargo.toml
parent51243007f67019d0d57b6cfaff2aec3191afa180 (diff)
feat(tvix/store): implement reflection r/5557
This implements grpc.reflection.v1alpha.ServerReflection, and will make tools
like evans automatically discover available services, without having to
specify the path to the .proto files client-side.

It's behind a reflection feature flag, which is enabled by default.

Change-Id: Icbcb5eb05ceede5b9952e38a2ba72eaa6fa8a437
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7435
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index 5cae4e0dfc..90672b6d03 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -15,9 +15,21 @@ tokio = { version = "1.23.0", features = ["rt-multi-thread"] }
 tokio-stream = "0.1.11"
 tonic = "0.8.2"
 
+[dependencies.tonic-reflection]
+optional = true
+version = "0.5.0"
+
 [build-dependencies]
 prost-build = "0.11.2"
 tonic-build = "0.8.2"
 
 [dev-dependencies]
 test-case = "2.2.2"
+
+[features]
+default = [
+  "reflection"
+]
+reflection = [
+  "tonic-reflection"
+]