about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-01-02T13·37+0100
committerflokli <flokli@flokli.de>2023-01-03T13·03+0000
commitceb2c0ba895554c7cabb0ac20d3a80ea2aba1ab1 (patch)
tree427ee29cd8883bc1159a58e7f6e92a8d673b155e /tvix/store/Cargo.toml
parentd0bbc8c8214fe164be572a0c2b1bd28f79fc1d20 (diff)
chore(tvix/store): make importable r/5569
This allows other crates to import tvix_store.

Rename the bin crate to tvix-store-bin, to avoid having multiple crates
with the same name (https://github.com/rust-lang/cargo/issues/6313)

Change-Id: I857768d6115640dbf102e79ed03e8474090df2fe
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7728
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index 111667cd74..abbd9b0dcb 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -1,8 +1,11 @@
 [package]
-name = "tvix-store"
+name = "tvix-store-bin"
 version = "0.1.0"
 edition = "2021"
 
+[lib]
+name = "tvix_store"
+
 [dependencies]
 anyhow = "1.0.68"
 blake3 = { version = "1.3.1", features = ["rayon", "std"] }