about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2022-11-11T23·40+0000
committerflokli <flokli@flokli.de>2022-12-04T10·41+0000
commit0a4a0d1c6ba20ba764da84568fabc6799cf9b0f1 (patch)
treedc111a3d81415f67154b6179def658bb6131f118 /tvix/store/Cargo.toml
parenta97e3726df33b45cf385f66b78c30615ab1f3856 (diff)
feat(tvix/store): add size() and digest() functions for Directory r/5386
Change-Id: I3a9e3c77da1d5d7bfb93da0cd7bce8d48dbc8cd4
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7254
Reviewed-by: Adam Joseph <adam@westernsemico.com>
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index 1b758be64b..c807da760a 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -4,6 +4,7 @@ version = "0.1.0"
 edition = "2021"
 
 [dependencies]
+blake3 = { version = "1.3.1", features = ["rayon", "std"] }
 prost = "0.11.2"
 
 [build-dependencies]