about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2022-12-28T16·17+0100
committerflokli <flokli@flokli.de>2022-12-30T20·25+0000
commit319c03f63413a82d9266ed939eba7f7e552dd2b2 (patch)
tree7ed69310905fd8f4d7250aca3eb0976119f62a70 /tvix/store/Cargo.toml
parent0bf2b0ef1164aae0ad692066e8cfc0b243a89e4d (diff)
feat(tvix/store): add logging with tracing r/5558
This uses [tracing](https://github.com/tokio-rs/tracing) for logs/
tracing.

Annotate all method handlers with an instrument macro, and warn! a
message for them being unimplemented.

Co-Authored-By: Márton Boros <martonboros@gmail.com>
Change-Id: Id42a41db33782d82abfb8dc0e49a8915000e5d89
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7665
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index 90672b6d03..111667cd74 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -14,6 +14,8 @@ thiserror = "1.0.38"
 tokio = { version = "1.23.0", features = ["rt-multi-thread"] }
 tokio-stream = "0.1.11"
 tonic = "0.8.2"
+tracing-subscriber = "0.3.16"
+tracing = "0.1.37"
 
 [dependencies.tonic-reflection]
 optional = true