about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2022-11-11T23·07+0000
committerflokli <flokli@flokli.de>2022-12-04T10·41+0000
commita97e3726df33b45cf385f66b78c30615ab1f3856 (patch)
treef6125b0315eaf81b457f4bdd88e593fcf6081cba /tvix/store/Cargo.toml
parentc432aae9b3a4924baa8b76cdc6f052f6fe70b730 (diff)
feat(tvix/store): build rust proto files r/5385
This uses prost-build to build the proto files.

Change-Id: Ia99fcfa4a19c741683cf28a45202e1d9211f9131
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7286
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Reviewed-by: Adam Joseph <adam@westernsemico.com>
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index 83e2de8d42..1b758be64b 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -4,3 +4,7 @@ version = "0.1.0"
 edition = "2021"
 
 [dependencies]
+prost = "0.11.2"
+
+[build-dependencies]
+prost-build = "0.11.2"