about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-02-13T15·47+0100
committerflokli <flokli@flokli.de>2023-03-10T10·58+0000
commit419f7d0f0c3dadeb0bbecda763aaec73ed8da8dd (patch)
tree0559440c1b67c5aa958e883439abb299b4fdb8e3 /tvix/store/Cargo.toml
parentab02fc668c23a4f0f262dd889278f2fc36793f9e (diff)
feat(tvix/store): add NARCalculationService trait and impl r/5918
This adds a NARCalculationService trait, which will take a root node,
and provide a proto::CalculateNarResponse in return.

It also adds a NonCachingNARCalculationService implementation, that will
simply always render the NAR in memory to calculate the size and sha256,
without any caching.

Change-Id: Id1ffb18559212fa6001f70f2634bbc3dfd0aa343
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8096
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml8
1 files changed, 5 insertions, 3 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index 769b496235..196e986b89 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -9,19 +9,21 @@ name = "tvix_store"
 [dependencies]
 anyhow = "1.0.68"
 blake3 = { version = "1.3.1", features = ["rayon", "std"] }
+clap = { version = "4.0", features = ["derive", "env"] }
+count-write = "0.1.0"
 data-encoding = "2.3.3"
+fastcdc = "2.0.0"
 lazy_static = "1.4.0"
-clap = { version = "4.0", features = ["derive", "env"] }
 prost = "0.11.2"
+sha2 = "0.10.6"
 sled = { version = "0.34.7", features = ["compression"] }
 nix-compat = { path = "../nix-compat" }
 thiserror = "1.0.38"
 tokio-stream = "0.1.11"
 tokio = { version = "1.23.0", features = ["rt-multi-thread"] }
 tonic = "0.8.2"
-tracing-subscriber = "0.3.16"
 tracing = "0.1.37"
-fastcdc = "2.0.0"
+tracing-subscriber = "0.3.16"
 
 [dependencies.tonic-reflection]
 optional = true