about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-02-27T12·03+0100
committerflokli <flokli@flokli.de>2023-03-10T10·58+0000
commitb29d1ae372bb0794cc8425ced7986b3d059a2be5 (patch)
tree05ecc2b78c6f005245c4896b1692e0ec4f529a05 /tvix/store/Cargo.toml
parent52a5181ebac94f7b6d5a1acab182d8f7fcc59c8c (diff)
feat(tvix/store): add import::import_path r/5932
This imports the contents at a given Path into the tvix store.

It doesn't register the contents at a Path in the store itself, that's up
to the PathInfoService.

Change-Id: I2c493532d65b90f199ddb7dfc90249f5c2957dee
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8159
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index 0a1ee9ce5c..09a62bc79f 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -24,6 +24,7 @@ tokio = { version = "1.23.0", features = ["rt-multi-thread"] }
 tonic = "0.8.2"
 tracing = "0.1.37"
 tracing-subscriber = { version = "0.3.16", features = ["json"] }
+walkdir = "2.3.2"
 
 [dependencies.tonic-reflection]
 optional = true