about summary refs log tree commit diff
path: root/tvix/shell.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-04-13T10·43+0300
committerflokli <flokli@flokli.de>2024-04-13T12·01+0000
commite5b87d549620a0745eef41afe665218c4c153442 (patch)
tree1fc22f0a46ad6f65af994651f6e4506b7100308f /tvix/shell.nix
parent31e3382129f6a750f2d2eec840cc7bb1c2db80ce (diff)
feat(3p/nixpkgs): add additionalOverlays optional arg r/7907
This allows applying additional overlays to nixpkgs before
instantiating it.

Change-Id: Iee486086e13bb73e6bd20a817b1106c3cd99c935
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11407
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--tvix/shell.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/shell.nix b/tvix/shell.nix
index bba20496a7..75e64b88b2 100644
--- a/tvix/shell.nix
+++ b/tvix/shell.nix
@@ -8,6 +8,7 @@
   pkgs ? (import ./nixpkgs {
     depotOverlays = false;
     depot.third_party.sources = import ./sources { };
+    additionalOverlays = [ ];
   })
 , ...
 }: