about summary refs log tree commit diff
path: root/tvix/shell.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-12-08T13·55+0300
committertazjin <tazjin@tvl.su>2022-12-15T17·26+0000
commit64f812b2f0ecd1b6759d8f2e4a9f05905f52e99d (patch)
treea8500fc19d2ff4b2244542de07dd198c6227c087 /tvix/shell.nix
parent3aca3d3bba54eaedefc7c472af8bca16ce1f163d (diff)
refactor(tvix): provide a combined //tvix:shell mkShell target r/5421
Manually maintained shell target based on the previous "loose"
`shell.nix` file.

We might want to have a function that combines the dependencies of all
the targets automatically, but at a quick glance that was actually
non-trivial so I'm leaving it as an exercise for someone else.

Change-Id: I74754940088f1b58e3b6754fb782470c80ea4292
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7540
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/shell.nix')
-rw-r--r--tvix/shell.nix17
1 files changed, 0 insertions, 17 deletions
diff --git a/tvix/shell.nix b/tvix/shell.nix
deleted file mode 100644
index e8d1e5e383..0000000000
--- a/tvix/shell.nix
+++ /dev/null
@@ -1,17 +0,0 @@
-{ depot ? import ../. { }
-, pkgs ? depot.third_party.nixpkgs
-, ...
-}:
-
-pkgs.mkShell {
-  name = "tvix-eval-dev-env";
-  packages = [
-    pkgs.buf-language-server
-    pkgs.cargo
-    pkgs.clippy
-    pkgs.rust-analyzer
-    pkgs.rustc
-    pkgs.rustfmt
-    pkgs.protobuf
-  ];
-}