about summary refs log tree commit diff
path: root/tvix/shell.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-10-16T13·44+0100
committerclbot <clbot@tvl.fyi>2023-10-16T15·09+0000
commit6aa8a1a8ea26a95be319a29fa893c10d9ee14d8f (patch)
tree33ced407af13437491f6edb4861715abb498b7f9 /tvix/shell.nix
parent652afd21b39fe7aabe81bb948ba4ba490422070d (diff)
fix(tvix/shell): fix cargo build on MacOS r/6836
It looks like we need Security Framework in the shell to be able to
imperatively run `cargo build`.

Change-Id: Ia5df9052bafca3610d4ed235b180b812d33d0d15
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9756
Tested-by: BuildkiteCI
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Autosubmit: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/shell.nix')
-rw-r--r--tvix/shell.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/tvix/shell.nix b/tvix/shell.nix
index 1a7e9ddd2b..62b7a404bc 100644
--- a/tvix/shell.nix
+++ b/tvix/shell.nix
@@ -12,9 +12,6 @@
 , ...
 }:
 
-let
-  iconvDarwinDep = pkgs.lib.optionals pkgs.stdenv.isDarwin [ pkgs.libiconv ];
-in
 pkgs.mkShell {
   name = "tvix-rust-dev-env";
   packages = [
@@ -29,5 +26,10 @@ pkgs.mkShell {
     pkgs.rustc
     pkgs.rustfmt
     pkgs.protobuf
-  ] ++ iconvDarwinDep;
+  ] ++ pkgs.lib.optionals pkgs.stdenv.isDarwin [
+    # We need these two dependencies in the ambient environment to be able to
+    # `cargo build` on MacOS.
+    pkgs.libiconv
+    pkgs.buildPackages.darwin.apple_sdk.frameworks.Security
+  ];
 }