about summary refs log tree commit diff
path: root/tvix/serde/Cargo.toml
diff options
context:
space:
mode:
authorIlan Joselevich <personal@ilanjoselevich.com>2024-08-28T21·54+0300
committerclbot <clbot@tvl.fyi>2024-08-29T14·37+0000
commit5a97888d8b9df1815cee3d577ea95a44f188434f (patch)
treebdda1eb049d9e8b607ba71bc9e7cb1e2e5dd769f /tvix/serde/Cargo.toml
parent2945a359b46862b3da79dec37fa8ccb2f751fa8a (diff)
chore(tvix): Migrate members to inherit deps from workspace r/8610
From now on we will add the dependencies and their version in the root
Cargo.toml and in order to enable the dependency for a workspace member
we set `workspace = true` in the member's Cargo.toml.

Change-Id: I9738c1cf99810b7ace87ca712c3ea965ba846e25
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12389
Autosubmit: Ilan Joselevich <personal@ilanjoselevich.com>
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/serde/Cargo.toml')
-rw-r--r--tvix/serde/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/tvix/serde/Cargo.toml b/tvix/serde/Cargo.toml
index 90952f3e79fd..fc5f08a2ddcd 100644
--- a/tvix/serde/Cargo.toml
+++ b/tvix/serde/Cargo.toml
@@ -5,5 +5,5 @@ edition = "2021"
 
 [dependencies]
 tvix-eval = { path = "../eval" }
-serde = { version = "1.0", features = ["derive"] }
-bstr = { version = "1.10.0", features = ["serde"] }
+serde = { workspace = true, features = ["derive"] }
+bstr = { workspace = true, features = ["serde"] }