about summary refs log tree commit diff
path: root/tvix/nix-daemon/Cargo.toml
diff options
context:
space:
mode:
authorVova Kryachko <v.kryachko@gmail.com>2024-10-29T18·00-0400
committerVladimir Kryachko <v.kryachko@gmail.com>2024-10-30T15·00+0000
commit9e294db8206ee8f8ed99887367222c2197c5c83c (patch)
treea36c6a2cc819024c0fa8fd12d9970901c2f9c3fc /tvix/nix-daemon/Cargo.toml
parenteb2ca5f07991cc526b22b1701896f40d38c46d46 (diff)
feat(tvix/nix-daemon): Initial skeleton for nix-daemon r/8878
The goal is to create a drop-in replacement nix-daemon that nix-cpp can
use as a `daemon` store.

Change-Id: Ie092047dcc6a24a3b8d8d1b808f3e6fd2c493bf2
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12711
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/nix-daemon/Cargo.toml')
-rw-r--r--tvix/nix-daemon/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/tvix/nix-daemon/Cargo.toml b/tvix/nix-daemon/Cargo.toml
new file mode 100644
index 000000000000..39b34019b424
--- /dev/null
+++ b/tvix/nix-daemon/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "nix-daemon"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+async-trait = "0.1.83"
+clap = { workspace = true, features = ["derive", "env"] }
+futures = { workspace = true }
+mimalloc = { workspace = true }
+nix-compat = { path = "../nix-compat" }
+tvix-castore = { path = "../castore" }
+tvix-store = { path = "../store" }
+tvix-tracing = { path = "../tracing" }
+tokio = { workspace = true, features = ["fs", "macros", "net", "rt", "rt-multi-thread", "signal"] }
+tokio-listener = { workspace = true }
+tracing = { workspace = true }
+
+[lints]
+workspace = true
+
+[features]
+default = ["otlp"]
+otlp = ["tvix-tracing/otlp"]
\ No newline at end of file