about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-04-19T13·07+0300
committerclbot <clbot@tvl.fyi>2024-04-19T19·22+0000
commitcd820d07d7b8b732928150365b73b8a67d3af26e (patch)
treeaabde85b13a871f866094ebdbee603188a94ba50 /tvix/nix-compat/Cargo.toml
parentd1ae5845bf1153d87e1d6e0034fe90e6a96d0f8d (diff)
chore(nix-compat): remove unused test-case and test-generator r/7975
This is especially nice, as it allows us getting rid of the other
versions of proc-macro2 and quote.

Change-Id: I9fdd012ee6c0ded3e18ec30504b83ac2032d1390
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11474
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--tvix/nix-compat/Cargo.toml7
1 files changed, 0 insertions, 7 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
index ebec6d937d..876ac3ecad 100644
--- a/tvix/nix-compat/Cargo.toml
+++ b/tvix/nix-compat/Cargo.toml
@@ -44,16 +44,9 @@ lazy_static = "1.4.0"
 pretty_assertions = "1.4.0"
 rstest = "0.19.0"
 serde_json = "1.0"
-test-case = "3.3.1"
 tokio-test = "0.4.3"
 zstd = "^0.13.0"
 
-[dev-dependencies.test-generator]
-# This fork of test-generator adds support for cargo workspaces, see
-# also https://github.com/frehberg/test-generator/pull/14
-git = "https://github.com/JamesGuthrie/test-generator.git"
-rev = "82e799979980962aec1aa324ec6e0e4cad781f41"
-
 [[bench]]
 name = "derivation_parse_aterm"
 harness = false