about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-04-18T09·57+0300
committerclbot <clbot@tvl.fyi>2024-04-18T12·12+0000
commit2c884b8bd2918974c1ad281aea28edb83d2d5661 (patch)
treeb4c8c6edd19cabedc4cd717c957ba0ce7fba01bb /tvix/nix-compat/Cargo.toml
parent019b6d260e15ca13848e9321e4b131ac533d69ad (diff)
feat(tvix/nix-compat): enable more features by default r/7954
There's no point in not enabling these, and rust-analyzer is quite
useless too.

nix-compat users outside of here can still explicitly disable default
features if they don't want to pull in these features.

Change-Id: I8f2f24e7734ad152d1733bc3421098fc91af290a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11455
Tested-by: BuildkiteCI
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: picnoir picnoir <picnoir@alternativebit.fr>
Diffstat (limited to '')
-rw-r--r--tvix/nix-compat/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
index 674734a0e9..ebec6d937d 100644
--- a/tvix/nix-compat/Cargo.toml
+++ b/tvix/nix-compat/Cargo.toml
@@ -9,6 +9,9 @@ async = ["tokio"]
 # code emitting low-level packets used in the daemon protocol.
 wire = ["tokio", "pin-project-lite"]
 
+# Enable all features by default.
+default = ["async", "wire"]
+
 [dependencies]
 bitflags = "2.4.1"
 bstr = { version = "1.6.0", features = ["alloc", "unicode", "serde"] }