about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-12-24T20·56+0200
committerclbot <clbot@tvl.fyi>2023-12-24T21·45+0000
commitacbb613e6147205ffadcf163afaf9076b4fbbb39 (patch)
tree18af47b4309699caabf881f947bca6e1e051fa4e /tvix/nix-compat/Cargo.toml
parent1f76c5b8639b41b986328d2ddfd0b5c886b3a5ae (diff)
chore(tvix): switch to upstream futures 0.3.30 r/7261
The bugs have been fixed,
https://github.com/rust-lang/futures-rs/pull/2801 and
https://github.com/rust-lang/futures-rs/pull/2812 were merged and ended
up in that release.

Change-Id: Iefd990d2d1719b884504093343e54e9c5258e2e2
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10414
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/nix-compat/Cargo.toml')
-rw-r--r--tvix/nix-compat/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
index cec5b7ac97..8e945cc4ee 100644
--- a/tvix/nix-compat/Cargo.toml
+++ b/tvix/nix-compat/Cargo.toml
@@ -14,7 +14,7 @@ bstr = { version = "1.6.0", features = ["alloc", "unicode", "serde"] }
 data-encoding = "2.3.3"
 ed25519 = "2.2.3"
 ed25519-dalek = "2.1.0"
-futures-util = { version = "0.3.28", features = ["io"], optional = true }
+futures-util = { version = "0.3.30", features = ["io"], optional = true }
 glob = "0.3.0"
 nom = "7.1.3"
 serde = { version = "1.0", features = ["derive"] }
@@ -23,7 +23,7 @@ sha2 = "0.10.6"
 thiserror = "1.0.38"
 
 [dev-dependencies]
-futures = { version = "0.3.28", default-features = false, features = ["executor"] }
+futures = { version = "0.3.30", default-features = false, features = ["executor"] }
 lazy_static = "1.4.0"
 serde_json = "1.0"
 test-case = "2.2.2"