about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-04-04T16·03+0300
committerclbot <clbot@tvl.fyi>2024-04-06T14·12+0000
commitf3d8c633f2b4c44a6911d751a2efd93ef926a8bf (patch)
treea00891ab1c9699baeb9848065634bcd00dcb7f5d /tvix/nix-compat/Cargo.toml
parent39276dc5b41fa5e756ebb8ae30b4d2ac91995be7 (diff)
feat(tvix/nix-compat/wire): introduce BytesWriter r/7857
This deals with writing byte packets of larger sizes to an underlying
AsyncWrite.

Its constructor receives the expected size. It also deals with writing
padding if flush/shutdown is called after writing all the payload.

Change-Id: I8acbf992467f3862ffb8c7d669e8c0c8eced14c1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11355
Reviewed-by: picnoir picnoir <picnoir@alternativebit.fr>
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: Brian Olsen <me@griff.name>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/nix-compat/Cargo.toml')
-rw-r--r--tvix/nix-compat/Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
index 6e3df0485d..6fc55d5c01 100644
--- a/tvix/nix-compat/Cargo.toml
+++ b/tvix/nix-compat/Cargo.toml
@@ -6,7 +6,7 @@ edition = "2021"
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
 [features]
-async = ["futures-util", "tokio"]
+async = ["futures-util", "tokio", "pin-project-lite"]
 
 [dependencies]
 bitflags = "2.4.1"
@@ -29,6 +29,10 @@ optional = true
 version = "1.32.0"
 features = ["io-util", "macros"]
 
+[dependencies.pin-project-lite]
+optional = true
+version = "0.2.13"
+
 [dev-dependencies]
 futures = { version = "0.3.30", default-features = false, features = ["executor"] }
 lazy_static = "1.4.0"