about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-01-31T11·18+0100
committerflokli <flokli@flokli.de>2023-01-31T13·26+0000
commitc27bacd905a14207edc56850fd4ef9383706b5c4 (patch)
tree197b49a52c0ab6a05196b82cbe2071b3eed5eaa0 /tvix/nix-compat/Cargo.toml
parent8ea93bb646456864088a2c93e9ab2c4ccae75cba (diff)
refactor(tvix): introduce nix-compat crate r/5788
Move nixbase32 and store_path into this.

This allows //tvix/cli to not pull in //tvix/store for now.

Change-Id: Id3a32867205d95794bc0d33b21d4cb3d9bafd02a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7964
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/nix-compat/Cargo.toml')
-rw-r--r--tvix/nix-compat/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
new file mode 100644
index 0000000000..484285e780
--- /dev/null
+++ b/tvix/nix-compat/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "nix-compat"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+anyhow = "1.0.68"
+data-encoding = "2.3.3"
+glob = "0.3.0"
+sha2 = "0.10.6"
+thiserror = "1.0.38"
+
+[dev-dependencies]
+test-case = "2.2.2"