about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-11-19T20·21+0200
committerclbot <clbot@tvl.fyi>2023-11-19T22·06+0000
commitbb18556bf37475b096d7d39ecd27becbe7cafa01 (patch)
tree1072c0e0eb46c6ff08ebf4259f92a5af633a1d6a /tvix/nix-compat/Cargo.toml
parent9322d29ea9660d9ec2b24ab494efd7d4cee6780f (diff)
feat(tvix/nix-compat): add narinfo::Signature::verify r/7042
This adds support for verifying signatures found in NARInfo files.

This still needs to be hooked together with the nix+http[s] backend.

Change-Id: Ic1c8ddbdecfb05cefca2492808388b0f7f3f2637
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10081
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/nix-compat/Cargo.toml')
-rw-r--r--tvix/nix-compat/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
index db6c772019..115c1b7397 100644
--- a/tvix/nix-compat/Cargo.toml
+++ b/tvix/nix-compat/Cargo.toml
@@ -12,6 +12,8 @@ async = ["futures-util"]
 bitflags = "2.4.1"
 bstr = { version = "1.6.0", features = ["alloc", "unicode", "serde"] }
 data-encoding = "2.3.3"
+ed25519 = "2.2.3"
+ed25519-dalek = "2.1.0"
 futures-util = { version = "0.3.28", features = ["io"], optional = true }
 glob = "0.3.0"
 nom = "7.1.3"