about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-07-31T15·50+0200
committerflokli <flokli@flokli.de>2023-10-16T12·26+0000
commit652afd21b39fe7aabe81bb948ba4ba490422070d (patch)
tree0458322f24934e39a7635b53a98fceff0f3d2b2f /tvix/nix-compat/Cargo.toml
parentc3fad811f4ad19eaa7c1a258b7a3188cda10da92 (diff)
feat(nix-compat): add bench for aterm parsing r/6835
Change-Id: Ie9416f0046b6ee0a02096a7712cdba9cc84db4f6
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9733
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Reviewed-by: Gabriel Doriath Döhler <gabriel.doriath.dohler@ens.fr>
Tested-by: BuildkiteCI
Autosubmit: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/nix-compat/Cargo.toml')
-rw-r--r--tvix/nix-compat/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
index 0fff23fc44..19030612c2 100644
--- a/tvix/nix-compat/Cargo.toml
+++ b/tvix/nix-compat/Cargo.toml
@@ -24,9 +24,14 @@ futures = { version = "0.3.28", default-features = false, features = ["executor"
 lazy_static = "1.4.0"
 serde_json = "1.0"
 test-case = "2.2.2"
+criterion = { version = "0.4", features = ["html_reports"] }
 
 [dev-dependencies.test-generator]
 # This fork of test-generator adds support for cargo workspaces, see
 # also https://github.com/frehberg/test-generator/pull/14
 git = "https://github.com/JamesGuthrie/test-generator.git"
 rev = "82e799979980962aec1aa324ec6e0e4cad781f41"
+
+[[bench]]
+name = "derivation_parse_aterm"
+harness = false