about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
authorVova Kryachko <v.kryachko@gmail.com>2024-11-12T04·15-0500
committerVladimir Kryachko <v.kryachko@gmail.com>2024-11-13T21·21+0000
commitfa9c067dc9b631363659b55053f5f6d4428eb8a4 (patch)
tree16b36ee54159658b33943296a5d1fda147c65635 /tvix/nix-compat/Cargo.toml
parent6aada9106209d431407c3a45f466ef59b3cff504 (diff)
feat(nix-daemon): Implement more nix daemon operations. r/8917
In particular QueryPathFromHashPart, QueryValidPaths, QueryValidDerivers

Change-Id: Ie6ad83cec5ce9580044b85e201e4e23394f87075
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12762
Tested-by: BuildkiteCI
Reviewed-by: edef <edef@edef.eu>
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/nix-compat/Cargo.toml')
-rw-r--r--tvix/nix-compat/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
index e9b44ddb7adf..160eb2c20c16 100644
--- a/tvix/nix-compat/Cargo.toml
+++ b/tvix/nix-compat/Cargo.toml
@@ -10,7 +10,7 @@ async = ["tokio"]
 wire = ["tokio", "pin-project-lite", "bytes"]
 
 # nix-daemon protocol handling
-daemon = ["tokio", "nix-compat-derive"]
+daemon = ["tokio", "nix-compat-derive", "futures"]
 test = []
 
 # Enable all features by default.
@@ -23,6 +23,7 @@ data-encoding = { workspace = true }
 ed25519 = { workspace = true }
 ed25519-dalek = { workspace = true }
 enum-primitive-derive = { workspace = true }
+futures = { workspace = true, optional = true }
 glob = { workspace = true }
 mimalloc = { workspace = true }
 nom = { workspace = true }