about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
authorIlan Joselevich <personal@ilanjoselevich.com>2024-08-07T21·21+0300
committerIlan Joselevich <personal@ilanjoselevich.com>2024-08-08T08·06+0000
commitf648f17ec3dd9b99d6271f607d62004c321b7c8f (patch)
tree5fe247815cc72c39675cf80f178d9c6865b5c93e /tvix/nix-compat/Cargo.toml
parent000fb856befa667bfc4ac36fe3794f97ad34a1bd (diff)
feat(tvix): Jemalloc -> MiMalloc r/8461
Use the faster and newer MiMalloc memory allocator for all endpoints in
the workspace.

Change-Id: Ic60237284ed168e46ec6e8f28e2710bae4385c6f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12149
Tested-by: BuildkiteCI
Reviewed-by: aspen <root@gws.fyi>
Diffstat (limited to 'tvix/nix-compat/Cargo.toml')
-rw-r--r--tvix/nix-compat/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
index 73928b1acd30..dc77c5cf0ad1 100644
--- a/tvix/nix-compat/Cargo.toml
+++ b/tvix/nix-compat/Cargo.toml
@@ -20,6 +20,7 @@ ed25519 = "2.2.3"
 ed25519-dalek = "2.1.0"
 enum-primitive-derive = "0.3.0"
 glob = "0.3.0"
+mimalloc = "0.1.43"
 nom = "7.1.3"
 num-traits = "0.2.18"
 serde = { version = "1.0", features = ["derive"] }
@@ -41,6 +42,7 @@ criterion = { version = "0.5", features = ["html_reports"] }
 futures = { version = "0.3.30", default-features = false, features = ["executor"] }
 hex-literal = "0.4.1"
 lazy_static = "1.4.0"
+mimalloc = "0.1.43"
 pretty_assertions = "1.4.0"
 rstest = "0.19.0"
 serde_json = "1.0"