about summary refs log tree commit diff
path: root/tvix/nix-compat-derive/Cargo.toml
diff options
context:
space:
mode:
authorBrian Olsen <brian@maven-group.org>2024-07-22T14·51+0200
committerclbot <clbot@tvl.fyi>2024-08-25T15·05+0000
commitced05a2bb6b66d30208520d0791f4fa298c429e2 (patch)
treed295eb9766db79df8f3053bc5022e24059012f16 /tvix/nix-compat-derive/Cargo.toml
parent9af69204787d47cfe551f524d01b1a726971f06e (diff)
feat(tvix/nix-compat-derive): Add deriver for NixDeserialize r/8586
This adds a nix-compat-derive derive crate that implements a deriver
for NixDeserialize implementations. This is to reduce the amount of
code needed to implement deserialization for all the types used by
the Nix daemon protocol.

Change-Id: I484724b550e8a1d5e9adad9555d9dc1374ae95c2
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12022
Autosubmit: Brian Olsen <me@griff.name>
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/nix-compat-derive/Cargo.toml')
-rw-r--r--tvix/nix-compat-derive/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/tvix/nix-compat-derive/Cargo.toml b/tvix/nix-compat-derive/Cargo.toml
new file mode 100644
index 000000000000..dea8ab5ab159
--- /dev/null
+++ b/tvix/nix-compat-derive/Cargo.toml
@@ -0,0 +1,32 @@
+[package]
+name = "nix-compat-derive"
+version = "0.1.0"
+edition = "2021"
+
+[lib]
+proc-macro = true
+
+[features]
+external = []
+default = ["external"]
+
+
+[dependencies]
+proc-macro2 = { version = "1.0.86",  features = ["proc-macro"] }
+quote = { version = "1.0.36", features = ["proc-macro"] }
+syn = { version = "2.0.72", features = ["full", "extra-traits"] }
+
+[dev-dependencies]
+hex-literal = "0.4.1"
+pretty_assertions = "1.4.0"
+rstest = "0.19.0"
+tokio-test = "0.4.3"
+
+[dev-dependencies.tokio]
+version = "^1.38"
+features = ["io-util", "macros"]
+
+[dev-dependencies.nix-compat]
+path = "../nix-compat"
+default-features = false
+features = ["async", "wire", "test"]