about summary refs log tree commit diff
path: root/tvix/nix-compat-derive/Cargo.toml
diff options
context:
space:
mode:
authorIlan Joselevich <personal@ilanjoselevich.com>2024-08-28T21·54+0300
committerclbot <clbot@tvl.fyi>2024-08-29T14·37+0000
commit5a97888d8b9df1815cee3d577ea95a44f188434f (patch)
treebdda1eb049d9e8b607ba71bc9e7cb1e2e5dd769f /tvix/nix-compat-derive/Cargo.toml
parent2945a359b46862b3da79dec37fa8ccb2f751fa8a (diff)
chore(tvix): Migrate members to inherit deps from workspace r/8610
From now on we will add the dependencies and their version in the root
Cargo.toml and in order to enable the dependency for a workspace member
we set `workspace = true` in the member's Cargo.toml.

Change-Id: I9738c1cf99810b7ace87ca712c3ea965ba846e25
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12389
Autosubmit: Ilan Joselevich <personal@ilanjoselevich.com>
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/nix-compat-derive/Cargo.toml')
-rw-r--r--tvix/nix-compat-derive/Cargo.toml17
1 files changed, 7 insertions, 10 deletions
diff --git a/tvix/nix-compat-derive/Cargo.toml b/tvix/nix-compat-derive/Cargo.toml
index 34b5b371fb8c..da6d6744e650 100644
--- a/tvix/nix-compat-derive/Cargo.toml
+++ b/tvix/nix-compat-derive/Cargo.toml
@@ -7,19 +7,16 @@ edition = "2021"
 proc-macro = true
 
 [dependencies]
-proc-macro2 = { version = "1.0.86",  features = ["proc-macro"] }
-quote = { version = "1.0.37", features = ["proc-macro"] }
+proc-macro2 = { workspace = true, features = ["proc-macro"] }
+quote = { workspace = true, features = ["proc-macro"] }
 syn = { version = "2.0.76", features = ["full", "extra-traits"] }
 
 [dev-dependencies]
-hex-literal = "0.4.1"
-pretty_assertions = "1.4.0"
-rstest = "0.19.0"
-tokio-test = "0.4.4"
-
-[dev-dependencies.tokio]
-version = "^1.39"
-features = ["io-util", "macros"]
+hex-literal = { workspace = true }
+pretty_assertions = { workspace = true }
+rstest = { workspace = true }
+tokio-test = { workspace = true }
+tokio = { workspace = true, features = ["io-util", "macros"] }
 
 [dev-dependencies.nix-compat]
 path = "../nix-compat"