about summary refs log tree commit diff
path: root/tvix/nar-bridge/default.nix
diff options
context:
space:
mode:
authorBrian Olsen <brian@maven-group.org>2024-08-15T23·06+0200
committerBrian Olsen <brian@maven-group.org>2024-08-15T23·37+0000
commit39ef171e001bae6ba14b6aa9b6df2f36139a44ee (patch)
tree70f2de109988fb70346e2e1e79f8fa0e53884020 /tvix/nar-bridge/default.nix
parentad92083dea72fcbfff67ec3ac492b0e695870a51 (diff)
chore(tvix): Retain original passthru in Rust builds r/8494
When using the runTests feature of crate2nix the derivation that runs the
tests is put into passthru.test but all default.nix files for Rust crates
in Tvix threw that away.

This commit retains passthru so that you can get access to the test
derivation.

Change-Id: I8b7b7db57a49069348f08c12c00a3b1a41a0c05b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12215
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/nar-bridge/default.nix')
-rw-r--r--tvix/nar-bridge/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tvix/nar-bridge/default.nix b/tvix/nar-bridge/default.nix
index 3e116a1fc02b..2f1384e8211f 100644
--- a/tvix/nar-bridge/default.nix
+++ b/tvix/nar-bridge/default.nix
@@ -4,7 +4,7 @@
   runTests = true;
 }).overrideAttrs (old: rec {
   meta.ci.targets = lib.filter (x: lib.hasPrefix "with-features" x || x == "no-features") (lib.attrNames passthru);
-  passthru = (depot.tvix.utils.mkFeaturePowerset {
+  passthru = old.passthru // (depot.tvix.utils.mkFeaturePowerset {
     inherit (old) crateName;
     features = [ "otlp" ];
   });