about summary refs log tree commit diff
path: root/tvix/glue/src/tests/tvix_tests/eval-okay-toxml-context.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-05-23T09·06+0200
committerclbot <clbot@tvl.fyi>2024-05-23T14·49+0000
commitec8d79f3db2fc3a5ab7af048209cc2cc5ab14bd3 (patch)
tree375a80f1d5a013f1d3299f830284a5fc812e29d9 /tvix/glue/src/tests/tvix_tests/eval-okay-toxml-context.nix
parenta4a313cdd28b30eff54b8455f11df9de32640548 (diff)
feat(tvix/eval): teach builtins.toXML context r/8163
XmlEmitter gains a NixContext field, and `write_typed_value` extends it
with all context elements present in the passed value.

Once all serialization is done, a into_context() function returns the
collected context, so we can construct a NixString with context.

Tests for this live in tvix-glue, as we use builtins.derivation, which
is not present in the tvix-eval crate.

Fixes b/398.

Change-Id: I85feaaa17b753885f8a017a54e419ec4e602af21
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11704
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: Alyssa Ross <hi@alyssa.is>
Diffstat (limited to 'tvix/glue/src/tests/tvix_tests/eval-okay-toxml-context.nix')
-rw-r--r--tvix/glue/src/tests/tvix_tests/eval-okay-toxml-context.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/tvix/glue/src/tests/tvix_tests/eval-okay-toxml-context.nix b/tvix/glue/src/tests/tvix_tests/eval-okay-toxml-context.nix
new file mode 100644
index 000000000000..933aa46022dd
--- /dev/null
+++ b/tvix/glue/src/tests/tvix_tests/eval-okay-toxml-context.nix
@@ -0,0 +1,14 @@
+[
+  # builtins.toXML retains context where there is.
+  (builtins.getContext (builtins.toXML {
+    inherit (derivation {
+      name = "test";
+      builder = "/bin/sh";
+      system = builtins.currentSystem;
+    }) drvPath;
+  }))
+
+  # this should have no context.
+  (builtins.hasContext
+    (builtins.toXML { }))
+]