about summary refs log tree commit diff
path: root/tvix/glue/src/tests/tvix_tests/eval-okay-fetchurl.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-04-22T17·05+0300
committerflokli <flokli@flokli.de>2024-04-23T12·41+0000
commit8181817e53f4c0da5d7dfa1a56e296fefd929bcb (patch)
tree9fe6ede59171f79d37ff954deb2bc8cfff9cc8ba /tvix/glue/src/tests/tvix_tests/eval-okay-fetchurl.nix
parentdfef3d18d177bbeadcc3000cc39ef0a16a566a1f (diff)
feat(tvix/glue/fetchers): support file:// URLs r/7996
Nix supports file:// - URLs for `fetchurl` and `fetchTarball`.

Convert the enums and function arguments to hold a URL type.
reqwest::Url is a re-export of the url crate, but they don't re-export
the parsing errors, and as we want to hold these in our Error types, add
it to Cargo.toml explicitly.

The Fetcher::download function now checks on the scheme, and either
opens the file locally, or does do a HTTP request as before.

Fetch gets its custom debug impl, removing potentially sensitive
username and password out of URLs.

Change-Id: I777db1fe487370e822cbfec4624034aca5e08045
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11504
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--tvix/glue/src/tests/tvix_tests/eval-okay-fetchurl.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/tvix/glue/src/tests/tvix_tests/eval-okay-fetchurl.nix b/tvix/glue/src/tests/tvix_tests/eval-okay-fetchurl.nix
index 80fe808c21..8a39101525 100644
--- a/tvix/glue/src/tests/tvix_tests/eval-okay-fetchurl.nix
+++ b/tvix/glue/src/tests/tvix_tests/eval-okay-fetchurl.nix
@@ -1,6 +1,8 @@
 [
-  # (fetchurl "url") cannot be tested, as that one has to fetch from the
-  # internet to calculate the path.
+  # (fetchurl "url") needs to immediately fetch, but our options without
+  # internet access are fairly limited.
+  # TODO: populate some fixtures at a known location instead.
+  (builtins.fetchurl "file:///dev/null")
 
   # fetchurl with url and sha256
   (builtins.fetchurl {