about summary refs log tree commit diff
path: root/tvix/glue/Cargo.toml
diff options
context:
space:
mode:
authorIlan Joselevich <personal@ilanjoselevich.com>2024-08-28T21·42+0300
committerclbot <clbot@tvl.fyi>2024-08-29T11·26+0000
commit2945a359b46862b3da79dec37fa8ccb2f751fa8a (patch)
tree417ef91beb55c07f9e299d5b172163cf740aa3c3 /tvix/glue/Cargo.toml
parent02ee4416260aeb86f39095f6a4e26d3c969f9a9e (diff)
chore(tvix): Bump versions of all compatible deps via cargo upgrade r/8609
This updates all the dependencies and their "minimum" versions in
Cargo.{lock,toml} to the latest compatible version using `cargo-edit`'s
`cargo upgrade` command that will eventually be merged into `cargo
update`.

Change-Id: Iccb2aa4a1c84a0465222244a0bd0cafe2a82e781
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12388
Reviewed-by: flokli <flokli@flokli.de>
Autosubmit: Ilan Joselevich <personal@ilanjoselevich.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/glue/Cargo.toml')
-rw-r--r--tvix/glue/Cargo.toml30
1 files changed, 15 insertions, 15 deletions
diff --git a/tvix/glue/Cargo.toml b/tvix/glue/Cargo.toml
index 7784e08f523c..a43f174c47c8 100644
--- a/tvix/glue/Cargo.toml
+++ b/tvix/glue/Cargo.toml
@@ -4,34 +4,34 @@ version = "0.1.0"
 edition = "2021"
 
 [dependencies]
-async-compression = { version = "0.4.9", features = ["tokio", "gzip", "bzip2", "xz"]}
-bstr = "1.6.0"
-bytes = "1.4.0"
+async-compression = { version = "0.4.12", features = ["tokio", "gzip", "bzip2", "xz"]}
+bstr = "1.10.0"
+bytes = "1.7.1"
 data-encoding = "2.6.0"
 futures = "0.3.30"
 magic = "0.16.2"
 nix-compat = { path = "../nix-compat" }
 pin-project = "1.1"
-reqwest = { version = "0.12.0", features = ["rustls-tls-native-roots"], default-features = false }
+reqwest = { version = "0.12.7", features = ["rustls-tls-native-roots"], default-features = false }
 tvix-build = { path = "../build", default-features = false, features = []}
 tvix-eval = { path = "../eval" }
 tvix-castore = { path = "../castore" }
 tvix-store = { path = "../store", default-features = false, features = []}
 tvix-tracing = { path = "../tracing" }
-tracing = "0.1.37"
+tracing = "0.1.40"
 tracing-indicatif = "0.3.6"
-tokio = "1.28.0"
+tokio = "1.39.3"
 tokio-tar = "0.3.1"
-tokio-util = { version = "0.7.9", features = ["io", "io-util", "compat"] }
-thiserror = "1.0.38"
-serde = "1.0.195"
+tokio-util = { version = "0.7.11", features = ["io", "io-util", "compat"] }
+thiserror = "1.0.63"
+serde = "1.0.209"
 serde_json = "1.0"
 sha2 = "0.10.8"
 sha1 = "0.10.6"
 md-5 = "0.10.6"
-url = "2.4.0"
-walkdir = "2.4.0"
-clap = { version = "4.4.0", default-features = false }
+url = "2.5.2"
+walkdir = "2.5.0"
+clap = { version = "4.5.16", default-features = false }
 
 [dependencies.wu-manber]
 git = "https://github.com/tvlfyi/wu-manber.git"
@@ -39,13 +39,13 @@ git = "https://github.com/tvlfyi/wu-manber.git"
 [dev-dependencies]
 criterion = { version = "0.5", features = ["html_reports"] }
 hex-literal = "0.4.1"
-lazy_static = "1.4.0"
+lazy_static = "1.5.0"
 mimalloc = "0.1.43"
 nix = { version = "0.27.1", features = [ "fs" ] }
 pretty_assertions = "1.4.0"
 rstest = "0.19.0"
-tempfile = "3.8.1"
-tokio-test = "0.4.3"
+tempfile = "3.12.0"
+tokio-test = "0.4.4"
 
 [features]
 default = ["nix_tests"]