about summary refs log tree commit diff
path: root/tvix/glue/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-06-12T21·17+0300
committerclbot <clbot@tvl.fyi>2024-06-12T23·43+0000
commitddd88a589b3a4610627ba5620e273f4d055541f0 (patch)
treef7fe710d6a98e3dc437c1c8517eaaedb994559ae /tvix/glue/Cargo.toml
parent842d6816bfa5a8f393719e4cb1e8bfc4d8c14174 (diff)
feat(tvix/glue/tvix_store_io): show progress info r/8255
In `store_path_to_node`, in case we need to build or fetch something,
render a progress bar, using the spinner for now.
We can upgrade this to a progress *bar* later.

Change-Id: I4a7cf5ef8f639076f176af9b39d276be3f37c8ff
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11793
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/glue/Cargo.toml')
-rw-r--r--tvix/glue/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/tvix/glue/Cargo.toml b/tvix/glue/Cargo.toml
index dcc46d599096..6968210c5efb 100644
--- a/tvix/glue/Cargo.toml
+++ b/tvix/glue/Cargo.toml
@@ -17,7 +17,9 @@ tvix-build = { path = "../build", default-features = false, features = []}
 tvix-eval = { path = "../eval" }
 tvix-castore = { path = "../castore" }
 tvix-store = { path = "../store", default-features = false, features = []}
+tvix-tracing = { path = "../tracing" }
 tracing = "0.1.37"
+tracing-indicatif = "0.3.6"
 tokio = "1.28.0"
 tokio-tar = "0.3.1"
 tokio-util = { version = "0.7.9", features = ["io", "io-util", "compat"] }