about summary refs log tree commit diff
path: root/tvix/glue/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-12-13T09·34+0200
committerflokli <flokli@flokli.de>2023-12-13T13·41+0000
commit3cdde8ad5a4650cbb248b070891daf72ccfc9af0 (patch)
tree5dcf095995373cc5ca64c6becdc52ff333512bf7 /tvix/glue/Cargo.toml
parent8b614809359439694d47d1804fff1a0bb44827bf (diff)
feat(tvix/glue): add some import tests r/7212
This creates a directory with a .keep file inside, and uses
"${path/to/there}" to coerce it to a string (and import it into the
store), ensuring it calculates the same store paths as Nix does.

Change-Id: Ie14ae075104ce278bc4f2cce93aab5762a2734d1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10343
Tested-by: BuildkiteCI
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Diffstat (limited to 'tvix/glue/Cargo.toml')
-rw-r--r--tvix/glue/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/glue/Cargo.toml b/tvix/glue/Cargo.toml
index 90ad275269..b0902b5c99 100644
--- a/tvix/glue/Cargo.toml
+++ b/tvix/glue/Cargo.toml
@@ -20,6 +20,7 @@ git = "https://github.com/tvlfyi/wu-manber.git"
 [dev-dependencies]
 criterion = { version = "0.5", features = ["html_reports"] }
 lazy_static = "1.4.0"
+tempfile = "3.8.1"
 test-case = "2.2.2"
 
 [[bench]]